Innowise CMS -julkaisujärjestelmä ja PHP 7.2

15.11.2018     Innowise    

Useimmissa hosting-palveluissa ja webhotelleissa siirrytään lähiaikoina käyttämään PHP-ohjelmointikielen uudempaa 7.2-versiota, kun aiemman 5.6-version tuki on päättymässä. Muutos edellyttää Innowise CMS -julkaisujärjestelmän päivitystä.

Mikäli tiedät, että www-sivustollenne on tulossa käyttöön PHP 7.2, ota meihin yhteyttä mahdollisimman pian, jotta julkaisujärjestelmän päivitys ja mahdolliset muut muutokset ehditään tehdä ajoissa ennen PHP-version vaihtumista.

Innowisen hosting-palveluissa PHP 7.2 tulee käyttöön 20.11.2018. Olemme yhteydessä mahdollisesta päivitystarpeesta. Päivityksen yhteydessä sivustolle tulee käyttöön uusin versio Innowise CMS -julkaisujärjestelmästä ominaisuuksineen, joten päivityksestä on muutakin hyötyä.

Miksi päivitys pitää tehdä?

  • Kyseessä on pakollinen palvelinohjelmiston päivitys, joka tehdään vanhan PHP 5.6:n tuen päättymisen vuoksi. Vanhan version käytön jatkaminen aiheuttaisi tietoturvariskin, sillä sille ei saada enää jatkossa tietoturvapäivityksiä.
  • PHP-version päivityksen seurauksena vanhemmalle PHP-versiolle tehdyt ohjelmat eivät toimi eli ne ovat yhteensopimattomia.
  • Tämän seurauksena mm. Innowise CMS -julkaisujärjestelmä tulee päivittää ja tehdä muut tarvittavat yhteensopivuuskorjaukset www-sivustolle.
  • Mikäli Innowise CMS -julkaisujärjestelmää ei päivitetä ajoissa, ei julkaisujärjestelmä ja www-sivusto toimi PHP 7.2:n tullessa käyttöön.

Kyse ei yleensä ole isosta päivityksestä, mutta se on käytännössä pakko tehdä, jotta www-sivuston toimintaan ei tule katkosta.

comments powered by Disqus